Documentation

This framework solution offers WordPress templates to improve the development of custom themes and plugins by integrating them with Composer and Lightweight MVC.

Server Requirements

The framework has a few system requirements:

  • PHP >= 5.4

Installing

This utilizes Composer to manage its dependencies. So, before using, make sure you have Composer installed on your machine.

Then follow the next steps:

Step: 1

Download the template of your choice (theme or plugin).

Step: 2

Copy the content of the release into your projects root folder.

Step: 3

Open your Command Prompt application and change directory to point to your project’s folder, where composer.json resides.

Type the following command:

composer install

This will install all the software dependencies of the template.

Step: 4

In order to prevent conflicts with other projects using this template, it is suggested to set a name and change its namespace.

To do this, type the following in the commando prompt:

php ayuco setname MyNewName

Replace MyNewName with the name of your choice.

You are ready to START!

Updating

Run the following command to update your project’s dependencies:

composer update